On 20th December, 2019 Twitter published a post on their blog informing about a recent issue which may have compromised user data specifically on Android.

I was going through my emails this morning and stumbled upon an email by Twitter. To my surprise, the email informed me about possible compromise of the account. The email strongly suggested users to update to “the latest version of Twitter for Android”.

Email regarding the security issue.

I was using Twitter Lite up until this issue. As soon as Twitter informed me about the possible compromise of the account, I cannot risk staying with Lite version and immediately switched. If you are also using Twitter Lite, you should immediately switch to “latest version of Twitter for Android” which is basically Twitter’s main app.

https://play.google.com/store/apps/details?id=com.twitter.android

Here’s the blog post by Twitter outlining the vulnerability within Twitter for Android.

Blog post informing about security issue with Twitter for Android